Streetdata Webportal - Unable to Login
Incident Report for Streetdata
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 11:35 AEDT
Update
This issue has now been resolved.

We apologise for any inconvenience this has caused.
Posted Feb 25, 2020 - 10:48 AEDT
Investigating
We are currently investigating an issue with our online web platform. When trying to login, it will currently be not working. The impacted page is:

- https://app.streetdata.com.au

Further updates will be provided shortly.
Posted Feb 25, 2020 - 10:29 AEDT
This incident affected: Web Portal.